Вывести на экран таблицу умножения

Вывести на экран таблицу умножения (от 1 до 9).

Перебрать во внешнем цикле числа от 1 до 9. Для каждого из них перебрать во внутреннем цикле числа от 1 до 9. Во внутреннем цикле выполнять умножение переменных-счетчиков внешнего и внутреннего циклов. Таким образом на одну итерацию внешнего цикла произойдет девять итераций внутреннего, и сформируется одна строка таблицы умножения. После каждой строки надо перейти на новую. Это делается во внешнем цикле, после того как закончится выполняться внутренний.

Для построения таблицы необходимо использовать форматированный вывод, т.е. задавать ширину столбцов, иначе произойдет сдвиг, т.к. количество цифр в каждой строке различно.

var i,j: byte;
begin
    for i:=1 to 9 do begin
        for j:=1 to 9 do
            write(i*j:4);
        writeln;
    end;
end.
   1   2   3   4   5   6   7   8   9
   2   4   6   8  10  12  14  16  18
   3   6   9  12  15  18  21  24  27
   4   8  12  16  20  24  28  32  36
   5  10  15  20  25  30  35  40  45
   6  12  18  24  30  36  42  48  54
   7  14  21  28  35  42  49  56  63
   8  16  24  32  40  48  56  64  72
   9  18  27  36  45  54  63  72  81
#include <stdio.h>
main() {
    int i,j;
    for (i=1; i<10; i++) {
        for (j=1; j<10; j++)
            printf("%4d", i*j);
        printf("\n");
    }
}
for i in range(1,10):
    for j in range(1,10):
        print("%4d" % (i*j), end='')
    print()
алг таблица умножения
нач
  цел i,j
  нц для i от 1 до 9
    нц для j от 1 до 9
      вывод i*j, " "
    кц
    вывод нс
  кц
кон

При отсутствии возможности задавать ширину поля для вывода таблица не получается.

for i=1 to 9
        for j=1 to 9
                print (i*j) + " ";
        next j
        print
next i

Поскольку в языке программирования Basic-256 отсутствует форматированный вывод, то как таковой таблицы не получается.