Сумма и произведение элементов массива

Заполнить массив вещественных чисел вводом с клавиатуры. Посчитать сумму и произведение элементов массива. Вывести на экран сам массив, полученные сумму и произведение его элементов.

  1. Присвоить переменной, в которой будет храниться сумма, значение 0, а переменной для произведения - значение 1.
  2. В цикле увеличивая индекс массива от начала до конца
    1. считывать с клавиатуры число и записывать его в текущую ячейку массива,
    2. увеличивать переменную с суммой на введенное число.
    3. умножать переменную с произведением на введенное число.
  3. В цикле увеличивая индекс массива от начала до конца вывести все элементы массива.
  4. Вывести сумму и произведение.
const N = 10;
var
    a: array[1..N] of real;
    sum, mult: real;
    i: integer;
begin
    sum := 0;
    mult := 1;
    for i:=1 to N do begin
        read(a[i]);
        sum := sum + a[i];
        mult := mult * a[i];
    end;
    for i:=1 to N do write(a[i]:5:2);
    writeln;
    writeln(sum:5:2);
    writeln(mult:5:2);
end.
4.3 2.3 4.5 3.3 8.3 1.2 8.3 9.1 2.3 3.6
 4.30 2.30 4.50 3.30 8.30 1.20 8.30 9.10 2.30 3.60
47.20
914812.11
#include <stdio.h>
#define N 10
 
main() {
    float a[10], sum, mult;
    int i;
    sum = 0;
    mult = 1;
    for (i=0; i < 10; i++) {
        scanf("%f", &a[i]);
        sum += a[i];
        mult *= a[i];
    }
    for (i=0; i < 10; i++) {
        printf("%.2f ", a[i]);
    }
    printf("\n%.2f\n", sum);
    printf("%.2f\n", mult);
}
a = [0]*10
s = 0
m = 1
for i in range(10):
    a[i] = float(input())
    s += a[i]
    m *= a[i]
print(a)
print(s)
print('%.4f'%m)
алг сумма элементов
нач
  цел N=10
  вещ таб a[1:N]
  вещ sum, mult
  цел i
  sum := 0
  mult := 1
  нц для i от 1 до N
    ввод a[i]
    sum := sum + a[i]
    mult := mult * a[i]
  кц
  нц для i от 1 до N
    вывод a[i], " "
  кц
  вывод нс, sum, нс
  вывод mult
кон
dim a(10)
sum = 0
mult = 1
for i=0 to 9
        input a[i]
        sum = sum + a[i]
        mult = mult * a[i]
next i
 
for i=0 to 9
        print a[i] + " ";
next i
print
print sum
print mult